Jump to content
  • 0
mylivemodels

Upgrade not seem to work for me?

Question

Hi, i bought The Logo Creator version 6.8.0 in the App Store 2015. But now this version does not work on my Mac after i made an update to my Mac. On The logo creator it say i can update for free to Version 7.2.9 but i cant figure out how to make this work. Upgrade does not work. It just reinstall a new version. Please tell how to make this work. Please help me.

Regards

  • Like 1

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Did you download that update from here?  

https://www.laughingbirdsoftware.com/free-design-software-download/

If not, that may be your problem. You are correct though, the update is FREE.

If that is where you got the update, and it still does not work for you, you will have to send in a support ticket to Laughingbird. Be sure to include which OS you haver upgraded to. I know he developes The Creator on a MAC, so it should work on the latest version.

You can submit a support ticket here:  https://laughingbirdsoftware.ticksy.com

If you do not hear back within a day, two at most, post on the Facebook page, or post back here and we'll try and chase him down for you! 

Share this post


Link to post
Share on other sites
  • 0

The problem seems to be that i'm on Mac and bought it on App store. The upgrade does not work for the App store and on Mac. Its the same i can't open up the new installation. It tells me...

''Looks like you don't want the free template set? In order to continue using the app, please click MORE INFO below.''

upgrade.thumb.png.f60b0a1ef3ecda41755cee53ca102038.png

I have open a ticket but i contact support before and no answer. So i think i properly can forget this Logo creator. Only for windows user and for buyers on this site not on App Store

Share this post


Link to post
Share on other sites
  • 0

There was a change that Apple made... that cause the program not to function The solution is a setting change ....you just need to change the setting. System Preference>>>>>Second area check the second box down.

Screen Shot 2018-11-19 at 1.51.02 PM.png

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×