1. New Software Notice alert!

    The new Web Graphics Creator (version 4.0) will be out soon.

    For now, version 3.0 is still active and works great on most Windows machines. It no longer runs on Macs using Lion or greater... (but the new version will fix this)

    So hang in there! It's almost done!

Win32 Agent EFO

Discussion in 'Web Graphics Creator' started by johne, Jan 13, 2007.

  1. johne

    johne

    Messages:
    6
    Trophy Points:
    0
    Hi,

    I have recently purchased WGC and been using it successfully. Today when I went to launch the program my anti-virus said that there was a trojan (Win32:Agent-EFO) in the xtras/resolution/resolution.x32 file.

    If I quarantine that file WGC still opens but with a director error, symbol expect <void> script error message.

    I have tried uninstalling and reinstalling but infection message and script error still appear.

    Any ideas?

    thanks

    j
     
  2. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    Johne,

    Hi and welcome to the forum.

    The last I remember the Win32 Agent EFO is a trojan/adware file. You will need to run an adware software to remove that file and then reinstall WGC. That should fix it.

    Let me know.

    HTHs
     
  3. johne

    johne

    Messages:
    6
    Trophy Points:
    0
    thanks for your reply.

    tried running adware remover (a couple in fact) but with no success. had the file scanned with one of those multi-online scanners. turns out my anti-virus (Avast) was the only one of about 14 to consider it infected.

    if i turn avast off error disappears and wgc runs correctly.

    trying to add file to exclusion list without success at the moment.

    j
     
  4. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
  5. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    Also have you ran your antivirus and other tools in safemode?
     
  6. johne

    johne

    Messages:
    6
    Trophy Points:
    0
    chris:

    downloaded and ran stinger. came up clean (ie did not reveal infected file).

    j
     
  7. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
  8. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    Well John I to am having this problem now. It does this on The Logo Creator and The Web Graphics Creator. I am looking into how to remove it.
     
  9. KD-did

    KD-did

    Messages:
    8,136
    Trophy Points:
    113
    Gender:
    Female
    Thanks for the warning.When I launched TLC this morning it told me two things there had been an AVAST update and I got the Avast Win32 Agent EFO warning and chose to ignore it...

    To reinstall back to where it was I suggest doing an uninstall, remove the TLC file under "Program files" getting a fresh download and re-installing.And when you see the warning choose to "move to chest" or ignore the Win32 Agent EFO warning.
     
  10. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    John I told Avast to delete the file when it came up on me. TLC runs just fine with no problems. WGC I still get the

    script error

    <void>

    and click on continue yes and it runs just fine with no problems. I have seen comments of needing to be removed and some that it is nothing serious. Me I am not taken a chance of it being something serious and leaving it on my PC. So I deleted it and I have had nothing bad happen from it.

    My :2cents:
     
  11. johne

    johne

    Messages:
    6
    Trophy Points:
    0
    mmm...seems to be spreading :question:

    Here's what I've done so far...

    1. I have scanned the file using at www.virustotal.com. Avast was the only one to detect any abnormality.
    2. Used the trend micro house call scan. it found a few other possible dangers but was clean on the resolution.x32 file
    3. Have used a couple of adware/malware scanners that flag anything with the file.

    At this stage it points to a possible false positive result (based on above results and that it only appeared with the new definitiosn download). For the moment I have added the file to my exclusion list and tonight I will send the file to Avast for checking re false positive.

    (with file added to exclusion list wgc runs fine)

    For those using avast see this thread re false positives: http://forum.avast.com/index.php?board=2;action=display;threadid=7779
     
  12. homesight

    homesight <img src="images/ranks/mod.png" />

    Messages:
    486
    Trophy Points:
    0
    Umm, has anyone come to the conslusion that maybe some of the scripting in the file appears to the anti-virus scanner as similar threat called Win32 Agent EFO. I'm betting their is no virus and it just thinks there is, especially since it's isolated it into a program. I too was duped and haven't yet tried to run the WGC, but i bet it wont work. My advice is leave it alone. AVG often finds program scripting that it thinks are viruses.

    Ryan.
     
  13. homesight

    homesight <img src="images/ranks/mod.png" />

    Messages:
    486
    Trophy Points:
    0
    PS. I meant Avast, and also turn it off, that fixes the problem for now.

    Ryan.
     
  14. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    Do not turn off your virus protection. You can hit ignore and keep working.
     
  15. johne

    johne

    Messages:
    6
    Trophy Points:
    0
    ok...seems like the new update fixes the problem.

    after a required restart i have removed the resolution.x32 file from the exclusion list and WGC is back working normally.



    j
     
  16. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    Yep my Avast got an update and I seem to be running just fine. Gotta love those bugs. :D
     

Share This Page