How to get Flash ads into website

Discussion in 'The Flash Ad Creator' started by neilA, Feb 18, 2006.

  1. neilA

    neilA

    Messages:
    5
    Trophy Points:
    0
    How do you get your flash ad into a website using html editor? When we upload the file, the files webpage, and the assets, and insert the file into the html code, all we get is a blank white spot in the center of the page where the ad was supposed to go and didnt load. When we upload the assets, al we get are the jpegs, and dont know what to do with them.
     
  2. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    neilA welcome to the forum.

    You have to make sure that you put your.swf file in the same directory as your index.html file on your server. Next you have to put an assets folder (name exactly like it is on your computer) in the same directory as your .swf and index.html file. Then you upload your assets in the assets folder you created. Don't forget your data file that is in your assets folder, it must be uploaded into your oniline assets folder.

    That is pretty much it.

    Make sure your onlnie assets folder s named exactly like the one on your computer.

    If Your Computer has this:

    your_assets

    Online must have the same thing:

    your_assets
     
  3. neilA

    neilA

    Messages:
    5
    Trophy Points:
    0
    But....

    This worked before for me whenI put the data from "My Ad's"_ Webpage into the html code, without uploading assets. Now, it says there's a "movie" there, but nothing comes up, and I do have all the plugins. I tried this again, uploading assets, but still, the same result. Does The Flash Ad Creator somehow use javascript or something like that?
     
  4. cybrnetico

    cybrnetico Staff Member

    Messages:
    1,139
    Trophy Points:
    0
    can you shows us the code you put into your html? Or did you get this resolved?
     
  5. neilA

    neilA

    Messages:
    5
    Trophy Points:
    0
    The html code

    In the center of my webpage, I entered the following(which I got from the webpage of the flash ad:<object width="290" height="340" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000">
    <param value="cyberintro.swf" name="movie">
    <param value="high" name="quality">
    <embed width="290" height="340" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" quality="high" src="cyberintro.swf"></embed> </object></p>
    <p>&nbsp;</p>

    I tried putting in only the embed, and also many variations on this exact code. What is the exact proper way to put this in my page to get an ad out?
     
  6. cybrnetico

    cybrnetico Staff Member

    Messages:
    1,139
    Trophy Points:
    0
    this how it should look

    what you posted is what you got from your html? everytime I export I get this code, See Below:

    Code:
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="425" height="425">
    <param name ="movie"value="leader.swf">
          <param name="quality" value="high">
          <embed src="leader.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="425" height="425"></embed>
     /object>
    Try to use this code, replace with your own variables, see if it makes a difference, make sure the swf files is in the same directory with your HTML AD
     
  7. cybrnetico

    cybrnetico Staff Member

    Messages:
    1,139
    Trophy Points:
    0
    ftp screenshot

    here is a sample how the ad show look on your ftp, added some tips also.
     
  8. neilA

    neilA

    Messages:
    5
    Trophy Points:
    0
    That's not working for me either. However, could the problem be that I'm not using FTP? I use ace-host.net, and have a "cpanel" where I go to a file manager and edit my sites using the html editor. I go into the code and add the flash code manually like that, however I don't get that same screen you do, nor do i get any options to export. I do have an ftp option on my menu, but there are no links to anything. What do you think is the problem?
     
  9. cybrnetico

    cybrnetico Staff Member

    Messages:
    1,139
    Trophy Points:
    0
    can you PM me with a screenshot of your file manager root directory and a link to your ad?
     
  10. neilA

    neilA

    Messages:
    5
    Trophy Points:
    0
    Unfortunately, I can't do screenshots;can you tell me from start to finish how to get this ad on my website? Perhaps if you tell me how you did it step by step, I'll be able to figure it out. I run a "cybermall" (crystaladvertising.com) for local businesses in my area, and I want a nice flash ad on the front page. Thanks for all your help.
     
  11. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    neilA you are gonna have to insert your HTML code into your website. Then upload the updated html page. Next you will have to get your flash file and assets onto your server. It will have to look just like cybr posted above, the layout. You could always try the HTML code I use for mine. I post it below. Just change the needed parts to point to your flash ad.

    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="503" height="117">
    <PARAM name="Movie" value="My Ad.swf">
    <PARAM name="Quality" value="High">
    <PARAM name="Scale" value="ExactFit">
    <PARAM name="Play" value="true">
    <PARAM name="Loop" value="false">
    <PARAM name="Menu" value="false">
    <PARAM name="SAlign" value="L">
    <EMBED src="My Ad.swf" width="503" height="117" Quality=High Loop=false Play=true Menu=false Scale=ExactFit type="application/x-shockwave-flash" pluginspace="http://www.macromedia.com/go/getflashplayer">
    </EMBED>
    </OBJECT>
     
  12. LogoManiac

    LogoManiac

    Messages:
    268
    Trophy Points:
    16
    side note...easy screenshots for the masses!

    Get Irfanview and install it. Irfanview is probably one of the best free image viewers available.

    Now, browse to the location you want to take a screenshot of, doesn't matter where...can be your harddrive via Windows Explorer or a location on the web via webbrowser.

    hit your Print Scrn button on your keyboard, open Irfanview, and Ctrl V(paste).
    VIOLA! You have your screenshot. Save to directory of your choice.

    .
     
  13. Pauls

    Pauls

    Messages:
    2
    Trophy Points:
    0
    is Problem with loading images?

    If u've problem with loading your images into your flash animation when ur site hosted, move all the files in the "My Ad_assets" directory to the same directory where ur html file and swf file.

    ie your html file, swf file and all files in the "My Ad_assets" directory should be (data.txt, imagefiles.gif..) in the same (level) directory.

    - Paul Robinson.
     
  14. investx

    investx

    Messages:
    2
    Trophy Points:
    0
    Same problem

    I'm having the same problem.

    1. Create the Flash Ad.

    2. Copy the OBJECT code and place into the HTML of my webpage.

    3. Upload all files, assets, SWF.

    I just get the default flash ad - with no content.

    If I run the SWF file - it works OK.
    But it won't work once it's been copied into another HTML.

    I've tried to see if it works by copying all the assets, files and SWF to the default folder where the HTML page - nothing. Still plays the default.

    It works fine in the original My Ad's_Webpage created by the program, but as soon as you take the object code and try to use it elsewhere, it won't work.

    Any ideas?
     
  15. investx

    investx

    Messages:
    2
    Trophy Points:
    0
    OK - I figured this out.....

    After much trial and error, I think I have figured out how to solve this.

    1. Create your Flash Ad.

    2. This creates an HTML page called My Ad's_Webpage.html (or whatever your call it instead of My Ad)

    3. This page is stored on your dirve in the same place as the assets folder, and the SWF file.

    4. You open the My Ad's_Webpage file and extract the <object > </object> code to insert on your home page, index page or whatever page you want your Flash Ad to appear on.

    5. You must SAVE the webpage you are working on, i.e. the hompeage, index page or whatever page it is you have inserted the object code to show your Flash Ad - SAVE this page to the SAME FOLDER as in 3 above. i.e. where the assets folder is, the SWF file is etc.

    Do not save it to a different folder - it won't work.


    Hope this helps others - as it worked for me!
     
  16. Chris

    Chris Staff Member

    Messages:
    3,062
    Trophy Points:
    38
    Gender:
    Male
    Hi investx,

    That is how it is suppose to be done. I just found your post and see that you already figure it out. AWESOME. I am a day late and a dollar short as they say. Well if you need help with anything else let us know.
     
  17. chuck9997

    chuck9997

    Messages:
    38
    Trophy Points:
    0
    never mind..
     
  18. Michael2008

    Michael2008

    Messages:
    6
    Trophy Points:
    0
    Hello Everyone

    I have the same problem but as investx stated :

    4. You open the My Ad's_Webpage file and extract the <object > </object> code to insert on your home page, index page or whatever page you want your Flash Ad to appear on.

    If you open this all I get is just the flash movie playing and how do you get this so call <object > </object> code to insert on your home page?

    Please HELP :image09: I cant get this flash to work on my website ?

    Thanks

    Michael
     

Share This Page