How do I default the BG to transparency only?

Discussion in 'General Support' started by Scripeon, Jun 1, 2014.

  1. Scripeon

    Scripeon

    Messages:
    26
    Trophy Points:
    3
    Gender:
    Male
    Hey guys, how do I default my bg to transparency only? I'm trying to start off with fresh templates, with no bg's. Thanks guys
     
  2. gunsmoke

    gunsmoke

    Messages:
    949
    Trophy Points:
    63
    Gender:
    Male
    Just create your design the way you want it. When you are ready, simply export as 'Tansparent PNG' and the background will be eliminated.
     
    gcuneo2 likes this.
  3. Scripeon

    Scripeon

    Messages:
    26
    Trophy Points:
    3
    Gender:
    Male
    hey gunsmoke!
    yeah, i've tried doing that and for some reason the background is saving along with it??
    That's how i've been doing things, but now for some reason it saves a background with it.. i'm confused lol?
     
  4. gunsmoke

    gunsmoke

    Messages:
    949
    Trophy Points:
    63
    Gender:
    Male
    Your not using a graphic background are you? Just a simple color? The background does not save if you select 'Transparent PNG'. Are you on a MAC or PC?
     
  5. Scripeon

    Scripeon

    Messages:
    26
    Trophy Points:
    3
    Gender:
    Male
    PC,
    I tried saving / export transparent .png, it still saves a background along with it.. TLC 6.8, latest.
     
  6. KD-did

    KD-did

    Messages:
    8,136
    Trophy Points:
    113
    Gender:
    Female
    Color a canvas and then import your TRANSPARENT png on it. What are you seeing a background on....there is no way to actually show no background..some viewers will give a designate color. Or perhaps there is a permanent background that is attached to the file and needs to be removed by an image editor before using.
     
    Last edited: Jun 1, 2014
  7. gcuneo2

    gcuneo2

    Messages:
    1,265
    Trophy Points:
    113
    Gender:
    Male
    NICE TO KNOW: JPG does not allow "layers" while PNG does....

    I am 99.99% certain why you are having this issue: You are manually importing an image, and then sending it to the back of the logo (Hey! it's a background, right?). Exporting as a transparent png only works correctly in TLC if you use the "FORMAT CANVAS" choice.

    The "format canvas" is important---I often will format the background a color just to see if any of my own graphics i created have any jagged edges.....


    This pix should help explain it....

    baby.jpg
     
    Last edited: Jun 2, 2014
    gunsmoke likes this.
  8. Scripeon

    Scripeon

    Messages:
    26
    Trophy Points:
    3
    Gender:
    Male
    Well i'm not trying to import a .png.. i'm just looking to figure out how to save my image, as a full.. into .png format.
    The background when a default file name and folder are used is a white background ?

    It just won't let me save to a .png with having a transparent background.
     
  9. gunsmoke

    gunsmoke

    Messages:
    949
    Trophy Points:
    63
    Gender:
    Male
    Sounds like you need to get with gcuneo2 for some live one on one help. It should work. Not sure what the problem is that you are having but maybe gcuneo2 can help you out.
     
  10. Scripeon

    Scripeon

    Messages:
    26
    Trophy Points:
    3
    Gender:
    Male
    Ok well first let me ask you Gunsoke, when you load TLC 6.8, does it have a white background? Or transparent background?
     
  11. gunsmoke

    gunsmoke

    Messages:
    949
    Trophy Points:
    63
    Gender:
    Male
    Some logos will have a background, some will not. Depends on where you start. If you can 'click' on the background and you get a box on the left with a button that says 'Format Canvas' then there is no background. This can be any color, white, black, or any other color. If you export that logo as a 'Transparent PNG' then that color will not be saved. Can you upload one of your logos that you saved as transparent png? Thanks.
     
  12. gunsmoke

    gunsmoke

    Messages:
    949
    Trophy Points:
    63
    Gender:
    Male
  13. Clikglobal

    Clikglobal

    Messages:
    3
    Trophy Points:
    1
    Gender:
    Male
    I am having the same exact issue. There is no background in the template I am using nor am I setting one but now when I export to transparent png I am getting a white background exactly like Scripeon.

    I am also using TLC 6.8
     
    Last edited: Jun 2, 2014
  14. gunsmoke

    gunsmoke

    Messages:
    949
    Trophy Points:
    63
    Gender:
    Male
    Clikglobal, are you on a PC or a MAC? Can you upload your 'transparent PNG' here so we can see what you're looking at? Thanks.
     
  15. Scripeon

    Scripeon

    Messages:
    26
    Trophy Points:
    3
    Gender:
    Male
    Yeah Gunsmoke I don't think that transparency is the default background in my TLC 6.8.

    I'll put in a tech support request for this..
     
  16. Clikglobal

    Clikglobal

    Messages:
    3
    Trophy Points:
    1
    Gender:
    Male
    Yes. I am on a PC and I will upload a file.

    What I am noticing is that the file is being saved with all caps .PNG extension.
    SMSmail_logo_1.PNG
    SMSmail_logo_1_green_png.PNG

    While it displays as transparent in Win7 using file explorer my linux hosted website software does NOT like the all cap .PNG extension and will not upload it into my website. I can use Filezilla or File Manager to upload and rename it but the website software still will not recognize it. I have to download the renamed file and then upload it again with the website software to get it to work.

    SMSmail_logo_2_green.png

    If I try to edit to a lower case .png extension its dropping the transparency and adding a white background. I tried a conversion program which also replaces the transparency with a white background.

    SMSmail_logo_1_converted.png

    Maybe this is a Windows - Linux thing but I do NOT experience this when using GIMP or Photoshop CC 6

    Regards
     
  17. gunsmoke

    gunsmoke

    Messages:
    949
    Trophy Points:
    63
    Gender:
    Male
    Has nothing to do with the file extension, and nothing to do with Linux or Windows. I use a GoDaddy Linux Shared Host and have absolutely no problem. Some servers have a problem with 'spaces' in filenames, but not the extension. However, if the extension is CAPS, then you have to match it when you try and access the file. So if you add that graphic to your website you have to CAP the extension. Most users simply rename the file using all lower case.

    All that said, that is not your problem with the background.

    If you look at the 4 graphics you uploaded, the third is a transparent PNG, so, what did you do different?

    You can see that in a website, on a linux server, here ... http://gunsmoke.me/test/test22/
     

    Attached Files:

    Last edited: Jun 2, 2014

Share This Page