Saving in PNG

Discussion in 'The Logo Creator' started by monyc, May 16, 2006.

  1. monyc

    Message Count:
    475
    Trophy Points:
    0
    Hello Lady and Gents:

    I am having a small issue, or maybe I am doing something wrong. I hope someone can help me out.

    Here is my small issue. When I use a ding bat size such as a circle. And import a image inside of the ding bat to give the image a round look, and save it in PNG thinking that the image would be save as a circle in a PNG format the image is saved like a standard image not a circle, But when I save the image in JPEG its saves like a circle.

    This has never happen to me before. I even tryed closing out all other software, restarting my computer and still it does not help. I even updated the software with the recent update. And still no luck.

    I have no idea whats going on here.
  2. KD-did

    Message Count:
    8,683
    Trophy Points:
    63
    Gender:
    Female
    Depending on your choice of export option and the colors used I could see that happening. Are you exporting in png or Tpng?
  3. monyc

    Message Count:
    475
    Trophy Points:
    0
    exporting to PNG, The First Png When you go to PNG, what is Tpng
  4. KD-did

    Message Count:
    8,683
    Trophy Points:
    63
    Gender:
    Female
    transparent png...if the dingbat is the same color as the background I could see how it would disappear.Much like "masking" works.
  5. monyc

    Message Count:
    475
    Trophy Points:
    0
    I had changed the background to grey and when I import a picture in side the circle dingbat. I does not take on the shape as the dingbat. It stays Square,
  6. KD-did

    Message Count:
    8,683
    Trophy Points:
    63
    Gender:
    Female
    You did send the image "back" so the ding bat would be on top? Are you using a circle or a ring dingbat?
  7. monyc

    Message Count:
    475
    Trophy Points:
    0
    I am using a circle ding bat. When I add the image to the dingbat. There is no other image for me to send back. Just the image in the dingbat.

    I even tryed putting a outline around the image in the digbat color it in black. save it in PNG. When I open the image all it has is the outline of where the dingbat should be.
  8. KD-did

    Message Count:
    8,683
    Trophy Points:
    63
    Gender:
    Female
    Sorry but I can't figure why there would be a problem.Maybe some one else could do it for you if you attach the image here.
  9. monyc

    Message Count:
    475
    Trophy Points:
    0
    This what I did, I went on google got a picture of New York City that I wanted to use. Which is square in shape. Went to text option found my circle that I wanted to use. Enlarge the dingbat. went to color and clicked import image.

    Now at this point there is only one image on my board. Now I clicked on PNG because I want to save the image in PNG without the white backing.

    When open the image its square not a circle.

    But thank you anyway for your help at least you tryed thank you again
  10. KD-did

    Message Count:
    8,683
    Trophy Points:
    63
    Gender:
    Female
    Okay, try this...Use you NY image cover with a square on top of it color it the background color. Cover that with your circle..you could use a solid circle element colored white then do a remove white background on the circle or try Tgif and use the eyedropper to choose the color of the circle..That should leave you with your image the way you want it.

    With the attachment here you would pick white to become transparent allowing the city image to show.
  11. monyc

    Message Count:
    475
    Trophy Points:
    0
    I will try it out and let you know the results. Thank you again.
  12. monyc

    Message Count:
    475
    Trophy Points:
    0
    I will try to explain with happening with my little show and tell. I hope this would come across a little clear than me trying to explain it.

    The 1st Image you see is the orb color in black and save in PNG. No problems there

    The 2nd Image you see is the image I would like insert into the orb. Save in PNG. There was no problems there.

    The 3rd image is with the image inserted into the orb ready to save in PNG.
    PROBLEM.

    Notice the image, it does not save as a orb but a square like my backround.

    But when I save the image in JPEG or TIff it save like it suppose to. But not in PNG Transperent.
  13. monyc

    Message Count:
    475
    Trophy Points:
    0
    here is the other images. The orb changes shapes once saved in PNG Transparent. But it keeps it shape once save in Tiff, JPEG. That is fine.

    But that white background is a issue This is the problem that I am having.
  14. laughingbird

    Message Count:
    3,576
    Trophy Points:
    48
    Gender:
    Male
    Hey Mony.

    The "Insert image into text" acts as a mask only from within The Logo Creator. As you've seen, the mask disapears once you export it as a transparent PNG.

    It all has to do with Alpha channels.
    May be a little much to go into here.

    There's got to be a work-around for this.
    I know Shelly (a Mod here in the forum) has had great success with masking images. Not sure if this will help, but view this page - see if it gives you any ideas: http://www.logodesignforum.com/forums/showthread.php?t=2149

    Another work around would be to export your image as a Jpeg (or regular PNG). Then, REimport it into a blank canvas. Choose "remove white backing" from the Modify menu. this will remove the white border.

    however, this may not provide the clean output you're after.

    See if any of the above work mony!

    Hey! TLC users - anybody have a suggestion on this one?
  15. KD-did

    Message Count:
    8,683
    Trophy Points:
    63
    Gender:
    Female
    I was able to do what you want( I think). I used a dingbat . I used the dingbat "basic button', the small letter a to produce a circle. I then did a image insert under "color' and was able to export a png.

    Here I used the forums light blue as a background color but if it were white then it enlarged you would not see it here.

    The second one I used a glass element which I faded a bit to give it more of a orb feel to it.
  16. laughingbird

    Message Count:
    3,576
    Trophy Points:
    48
    Gender:
    Male
    Hmmm.

    Yes, I see you exported as a PNG, but I think Mony wanted the PNG to be transparent. I see a slight, square, border surrounding your circle.

    - Marc
  17. KD-did

    Message Count:
    8,683
    Trophy Points:
    63
    Gender:
    Female
    Yes..and I explained that I had colored the background for the thimbnail BUT if it were white when enlarged it would disappeared.
  18. monyc

    Message Count:
    475
    Trophy Points:
    0
    Hey thank you guys:

    Here is the image I did with all of your help I was able to get it up and going again. Thank you again

    Mo

Share This Page