1. New Software Notice alert!

    The new Web Graphics Creator (version 4.0) will be out soon.

    For now, version 3.0 is still active and works great on most Windows machines. It no longer runs on Macs using Lion or greater... (but the new version will fix this)

    So hang in there! It's almost done!

Flipbook Issues

Discussion in 'Web Graphics Creator' started by amj, Oct 5, 2007.

  1. amj

    Message Count:
    18
    Trophy Points:
    0
    2 issues

    I have your web graphics software on a PC. I created my flip book but it doesn’t show when I add it to Microsoft Frontpage and publish. I have all the files on the server together. Are there any suggestions? I am a teacher and I’m getting frustrated. I purchased this software just for the flipbooks to showcase the students work. I surely hope I’m doing something wrong and it not that the software doesn’t work with Frontpage.

    I can only import a folder of images to the flipbook and not one image at a time. When I click on upload an image, the script box pops up, I say no and it shuts the program down. Any suggestions?

    Please, please, please help.
  2. KD-did

    Message Count:
    8,724
    Trophy Points:
    63
    Gender:
    Female
    Did you do a "refresh" after publishing? I remember having to refresh when using Front Page.
  3. amj

    Message Count:
    18
    Trophy Points:
    0
  4. KD-did

    Message Count:
    8,724
    Trophy Points:
    63
    Gender:
    Female
    Are you sure your host can handle .swf files?
  5. Chris_Houg

    Message Count:
    479
    Trophy Points:
    16
    Did you upload the files from and create a book_images directory? It looks like your config.xml is looking for the files in that directory.

  6. amj

    Message Count:
    18
    Trophy Points:
    0
    I'll definitely try

    I'll definitely look into the 2 suggestions first thing Monday morning when I return my school. Thanks guys.
  7. amj

    Message Count:
    18
    Trophy Points:
    0
    I looked into both suggestions. My server can handle swf files and the images are on the server. Should these files be grouped in or folder or does it matter as long as they are on there? I've tried both ways.

    Any other suggestions?
  8. Chris_Houg

    Message Count:
    479
    Trophy Points:
    16
    Is it a linux server and not a Windows server? If it is linux, you need to edit the config.xml file and change the backslashes "\" to a forward slash "/" and they should start working.
  9. amj

    Message Count:
    18
    Trophy Points:
    0
    flipbook and FP

    I'll check into that now...thanks
  10. amj

    Message Count:
    18
    Trophy Points:
    0
    flipbook FP issue

    Do I need to change all of them...there's a lot?
  11. Chris_Houg

    Message Count:
    479
    Trophy Points:
    16
    Unfortunately, yes, otherwise the image won't load. I've counted only 22 in the config.xml file so it shouldn't take that long. You can do it quickly by opening the file in textpad and do a find/replace of image\ to image/ and it will do it real quick. Then just upload config.xml and replace the existing one.

    Also, I don't seem to find the book_images directory in your TinsleyES directory. If they aren't pointing to where the actual image is on your site, it won't find the image and won't load.
  12. amj

    Message Count:
    18
    Trophy Points:
    0
    I changed the backslashes to forward slashes but that didn't work. The slashes were in all images. I didn't see them anywhere else in the config file. Any other suggestions?
  13. Chris_Houg

    Message Count:
    479
    Trophy Points:
    16
    When I type:

    http://es.houstonisd.org/TinsleyES/book_images/Cakendrea.jpg

    into my browser, I should be able to view that image but I'm getting an error message that it's not found. What would be the URL to one of the images? This will help find out what should be in your config.xml for the file location.

    I'm not sure that Front Page will upload the images correctly when you publish it. You may have to upload them via your control panel or an ftp client.
  14. amj

    Message Count:
    18
    Trophy Points:
    0
  15. Chris_Houg

    Message Count:
    479
    Trophy Points:
    16
    Oops, my mistake, but the program wouldn't have found the file anyway because it is looking for the images in a book_images directory and you have them in the same directory.

    If they are in the same directory, try replacing the pages section with this one:

    and see if that doesn't fix it for you.

    The directory structure should be maintained for it to work correctly and if you change it, you need to change the config.xml file accordingly (or if Front Page changes it :image28: )
  16. amj

    Message Count:
    18
    Trophy Points:
    0
    Flipbook & FP

    Chris your awesome. That did the trick. I was doing crazy stuff trying to get it to work. I did have them in an images folder at first but thought that that was the problem so I pulled them out of the folder.

    I set the book size to be much larger, do you know why it's so small?

    Do I need to change the slashes everytime (it's not a problem, just wondering)?
  17. amj

    Message Count:
    18
    Trophy Points:
    0
    Flipbook

    Something I just noticed. My flipbook looks as I planned it to look in Firefox but not in IE. Anyone know why Firefox shows the flipbook correctly but it's too small in IE and cuts off the images.
  18. Chris_Houg

    Message Count:
    479
    Trophy Points:
    16
    Hopefully someone with a bit more knowledge on this can help you out. I'm guessing it's some of the parameters set in the html code. Here's what you have:

    Your pictures are 800X600 and FireFox seems to be doing ok with these settings but IE measured 300 pix total width for the book so each picture would get about 150 pix wide and the height of the book was measured at 225.

    I noticed in the html right after 'codebase' is 300 pix wide so maybe if you increase that 300 to 600 it will show up bigger?

    I'm guessing here but may be worth a try.
  19. Chris_Houg

    Message Count:
    479
    Trophy Points:
    16
    Took some more measurements in the FireFox version. It's showing up approximately 800 total width by 320 high or about 400 pix wide per picture. You may want to try 800 X 320 and see if that does anything.
  20. Chris

    Message Count:
    3,351
    Trophy Points:
    38
    Gender:
    Male
    Yes do as Chris says. Change the sizes in this code:

    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="300" height="225">


    To match the sizes in this part of the code:

    <embed src="MyFlipBook.swf" wmode="transparent" width="800" height="320" quality="high" bgcolor="#FFFFFF" flashvars="xmlConfig=config.xml" scale="noscale"

    Seems one browser might read the book as one size and the other as the other size.

    HTHs

Share This Page